Erianna

Nginx 1.6 & Nginx 1.7 Now Available

April 23rd, 2014 @ 22:30 Ubuntu Packages

Nginx 1.6 & Nginx 1.7 Now Available

Nginx recently announced the immediate availability of Nginx 1.7 mainline and Nginx 1.6 to address a security issue with SPDY protocol (CVE-2014-0133). Both packages have been updated on deb.erianna.com to address this security issue.

If you're already using deb.erianna.com, this package can be installed by running the following commands:

apt-get update
apt-get install nginx-mainline # Nginx 1.7
# OR # apt-get install nginx   # Nginx 1.6

If you're not using deb.erianna.com, you can read about how to setup the repository here.

Packages are available for precise, raring, quantal, saucy, and trusty, and can be downloaded directly from deb.erianna.com


Interested in Building Nginx Yourself?

If you're interested in building your own nginx package, head over to my github page, where you can download the script I use to install and package nginx.

cd ~ git clone https://github.com/charlesportwoodii/nginx-build cd nginx-build sudo sh build-nginx.sh <version>